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This manual is copyrighted by Shenzhen Technology Co., Ltd., without the 

written permission of the Zmotion Technology, no person shall reproduce, 

translate and copy any content in this manual. 

ZMC controller software involved in details as well as the introduction and 

routines of each instruction, please refer to ZBASIC software manual. 

Information contained in this manual is only for reference. Due to improvements 

in design and functions and other aspects, Zmotion Technology reserves the final 

interpretation! Subject to change without notice! 

       

Pay attention to safety when debug the machine! Be sure to design effective 

safety devices in the machine     and add error handling procedures in software. 

Zmotion has no obligation or responsibility for the loss. 
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Chapter I ZDevelop Overview 

ZDevelop is a green development software that integrates machine vision and motion control 

functions developed by ZMOTION. It supports ZBaisc, ZPLC, ZHMI and ZVISION machine vision 

secondary development. Also, there are many functions, it can hybrid program, achieve simulation, 

track online, diagnose and debug. What’s more, vision positioning, measurement, identification and 

detection of intellectual equipment can be realized rapidly, and complex motion control systems can 

be developed. ZDevelop software development page refers to below. 

Users can connect PC and controller through serial port or net port, program written by ZDevelop 

software can be downloaded into ZMOTION motion controller to run offline or simulate on PC. 

 

ZDevelop software supports 3 programming methods, Basic, PLC ladder of diagram and HMI 

configuration. Please note when using Basic language, it can run multiple Basic tasks. For PLC or 

HMI, it only supports one PLC task or one HMI task. Multi-task can be achieved among Basic, PLC 

and HMI. 

ZDevelop software supports online simulation debug, and it has simulator “ZMC Simulator” and 

configuration program simulation tool “xplc screen”. 

1.1  System Requirements 

To operate ZDevelop, minimum PC hardware configuration required as below:   

Items Minimum Recommended 
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CPU Pentium level, dominant frequency:450Mhz Pentium level, dominant frequency:1GHz  

Memory 64 MB 256MB 

Hardware Disk 20MB 100MB 

Operation System Windows 98, Windows xp  Windows xp or win7.  

Display 800x600/256 true color 1024x768/24 bits true color 

Communication RS232 
RS232/USB/Ethernet (converted by 

HUB) 

1.2  ZDevelop Usage Steps 

Build a new folder in computer to save item that is going to be built. Open ZDevelop program 

software. Here take Zdevelop version V3.10 as example, please visit ZMOTION website for 

updating software. Website: zmotionglobal.com 

Basic process: build a new project → build a new file → add automatic run task NO. in file 

→ edit the program → connect to controller → download the program into controller. 

    1. New build item: “File” in “Menu” → “New Project”. 

 

Click “New Project”, then “Save as…” will be jumped, select one folder and open it. Input 

folder’s name and save the project, pay attention to the suffix should be “.zpj”. 

http://www.zmotionglobal.com/
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2. New build a file: “File” → “New File”. 

 

  After clicking “New Project”, below jumping window will appear, which supports 

Basic/PLC/Hmi hybrid programming. Here selects the “Basic” file type and click “OK”. 

 

3. Set file as automatic operation: please see the below picture, double click the right position 

“AutoRun” of “File”, and input task number is “0”. 
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4. Program the procedure: when procedure is programmed, click “save” the file. New built 

Basic file will be saved automatically into the file in Project zpj. 

5. Connect to Controller: program the procedure well in the input window, click “Controller” 

- “Connect”. 

If there is no “Controller”, select connect to simulation, click “Connect” – “Connect to 

Simulator”. In this way, it can be connected to simulator, and there is hint showing simulator is 

connected successfully. 

 

Click “Connect”, then “Connect to Controller” window will jump. And select serial port 

parameters or net port IP address, click “Connect”. When it is connected well, print information in 

Command and Output window: Connect to Controller: ZMC432 Version: 4.64-20170623. 

 

For the detailed method of serial port connection and network port connection, please refer to 

the next Link ZDevelop to Controller. 

6. Download Program: click “Download RAM” or “Download ROM”. When it is downloaded 
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successfully, Command and Output window will give a hint. Program is downloaded into controller 

and will run automatically. 

✓ Download RAM: 

 

✓ Download ROM: 

 

Precautions:  

➢ When open the project item, select the item zpj file. If only the Bas file is opened, program 

can’t be downloaded into controller. 

➢ ZMC00x series controller don’t support Download RAM. 

➢ When project is not built, only Bas file can’t be downloaded into controller. 

➢ AutoRun 0 means the task number, task number 0 runs the procedure. Task number doesn’t 

have priority. 

➢ If all files of whole project are not set the task number, when downloading into controller, 

system will give the indication: WARN: no program set autorun. 

 

1.3  Link ZDevelop to Controller  

Through “Controller” – “Connect”, it can connect with controller. 

ZDevelop supports serial port and Ethernet connecting to controller. 

 

Through Serial Port: 
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Click menu: Controller > Connect, enter link configuration page, set serial parameters: com 

number, baud rate, parity bit, stop bit, then click “Connect” to link controller. 

On the other hand, we can also link controller through USB: link USB port on PC side, and 

link serial port on controller side, in this way, we have to install related drive file on PC, to generate 

a virtual serial port mapped to USB connection, so we configure the virtual serial port same as actual.   

 

If fail to link controller through serial port, possible reasons and solutions are as follow: 

1.serial connection wire is not cross type; 

2.COM configuration is not matched to PC Com, try to adjust the PC Com parameters as 

entering “device manage” page.  

 

We can also change Com number by entering “Advanced Setting” page of COM. 
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3.When linked to controller, controller should be configured as MODBUS slave mode (default 

mode), and it will recover through power off – power on. 

4.COM port on PC side was occupied by other application, like, serial port debug assistance. 

5.Serial ports are not enough in PC. 

6.Serial wire or PC is wrong.  

Through Ethernet: 

When select IP in IP address list, it will find available controller IP address in current local 

ethernet range. 

The default IP address is 192.168.0.11, “Controller” – “Connect” window can show this IP 

address, and it can be connected only when PC IP address is in same net segment as controller IP, 

which means the front 3 segments should be the same, the last segment is different. 

VPLC5XX series controllers include 2 net ports, LAN1 and LAN2. (default address of LAN1: 

192.168.0.11, default address of LAN2: 192.168.1.11) 

Please see below, “Connect to controller” window, native IP can be checked quickly. Note: 

wired network card and wireless network card should be set separate IP. 

 

When there are multiple controllers in same network, it can be checked through IP scanning. 
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Modify IP address on PC side: 

Check whether the computer's local IP protocol version 4 address is 192.168.0.xxx, the first 

three segments are consistent with the controller, and the last cannot be the same. The factory default 

IP of the controller is 192.168.0.11. If the third segment of the IP address is different, the 

corresponding subnet mask needs to be as 0. After setting, connect the software again. 

 

 

Modify IP address on controller:  

If the controller IP is modified and is not in the network segment 192.168.0.XXX, you can only 

connect the controller through the serial port first, obtain the controller IP address, and then modify 

the local IP or the controller IP so that the two are on the same network part. 

There are many ways to modify the IP address of the controller. You can click "Controller" - 

"Modify IP Address" in the menu bar, and the following window will pop up. At this time, the 

current controller IP will be displayed, and you can directly enter the new IP address in the window. 
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Or in “Controller”-“State the controller’ to see, or through online command, then use 

IP_ADDRESS to modify IP. 

 

After modifying, controller and ZDevelop will disconnect, now, select new IP address to 

connect. 

1.4  Link ZDevelop to simulator 

Online simulation is valid in ZDevelop, it enables project simulation or program debug when 

hardware is not available. 

Click menu: Controller > Connect to simulator, to open link simulator, also it can be connected 

through IP:127.0.0.1. 

After successful connection, followed information will be printed: 

 

Please note: old versions don’t support simulation visual instructions, so update latest version. 

If project contains HMI file, click “Zhmi” button to pop HMI interface. 
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One certain HMI example project is below:  

 

1.5  Help 

Click "Help" on the menu bar, open the controller usage documentation, ZBasic grammar help 

document, ZPlC grammar help document, ZHmi grammar help document, ZVision visual syntax 

help document, and ZDevelop development environment help document. In the document, you can 

view the description of all related commands and the introduction of some functions.  

 

In the Basic program, select an instruction and then press the F1 key to quickly open the 

instruction detailed description page in the help document in the help view window, as shown in the 

figure below. The F1 shortcut key is also supported under PLC and HMI programming. 

In the help interface, hold down Ctrl and scroll the mouse to zoom in and out of the displayed 

content of the help document. The HOME key jumps to the beginning of the current line, the END 

key jumps to the end of the current line, pageup and pagedown are page up and down. 

ZBasic Help:  
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(but there is no English help document in software, it can be checked here). 

1.6  Language Switch 

Now, ZDevelop supports Chinese and English, through “视图”-“语言”, then restart. 
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Chapter II Controller Operation 

Controller status or configuration can be accessed through ZDevelop if it was built with 

controller. 

2.1  Controller Status 

Click menu controller > State the controller to view controller status, as below: 

“Controller State” shows controller status information, including controller basic information, 

ZCan node status, slot node status and communication configuration. Node state can show the axis 

number of connected device, start IO number, etc. 

Basic information includes the max virtual axes, max motor axes, task, file, space of each 

register, procedure volume, controller model, software version NO. and time, IP address, hardware 

version NO., controller hardware ID and configured type and map on each axis, etc. 

 

VirtualAxises: max virtual axes 

RealAxises: max actual axes 

Taskes: max tasks 

Files/3Files: max files/max .Z3P file 

Modbus0x Bits: max modbus bits 

Modbus4x Regs: max modbus words 

VR Regs: max VR number 

TABLE Regs: max Table number 

RomSize: Rom size 

FlashSize: Flash size 

SoftType: software type 

SoftVersion: system version and firmware version 

IpAddress: controller IP address 
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HardVersion: hardware version 

ControllerID: controller unique ID 

Axis features list: axes type list 

ZCan Node： 

 

The first line of LOCAL node shows that hardware is VPLC516E controller, the first line 

corresponds to the local resources of the controller, supports 64 axes, a total of 27 digital inputs, 

numbered IN(0)-IN(26), and a total of 15 digital outputs , numbered OP(0)-OP(26), without AD, 2 

DA, numbered DA(0)-DA(1). 

Lines 2 to N display information about the extension modules of the ZCan node. 

For example, the hardware of CanID node 2 is ZAIO0802, no digital input, no digital output, 

AD has 8, numbered AIN(24)-AIN(31), DA has 2, numbered AOUT(12)-AOUT(13 ). 

The hardware of CanID node 4 is ECI0016PA, 8 digital inputs, numbered IN(80)-IN(87), 8 

digital outputs, numbered OP(80)-OP(87), AD has 12, numbered AIN( 40)-AIN(51), DA has 2, 

numbered AOUT(20)-AOUT(21). 

Slot 0 node: 

Slot 0 is for EtherCAT in EtherCAT controller, for RTEX in RTEX controller; 

If EtherCAT and RTEX both are supported in controller, then Slot 0 is for EtherCAT, Slot 1 

is for RTEX. 

 

The left is the most basic EtherCAT initialization procedure. 

Right shows that Lines 2 to N include the extension modules of the ZCan node. 

See below, The hardware manufacturer ID of EtherCAT node 0 is 41bh (manufacturer ID of 

ZMOTION), the device ID of hardware manufacturer is 0h (product ID0 of ZMOTION, the 

corresponding product is EIO1616), dial number 0, no axis expansion, digital quantity 16 inputs, 
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numbered IN(96)-IN(111), 16 digital outputs, numbered OP(96)-OP(111), no AD, no DA. 

Controller communication configuration:  

In Communication page, information of CAN, RS232, RS485 and RS422 is shown: 

 

CAN Communication Setting： 

When set CANIO_ADDRESS=32, CANIO_ENABLE=1, it means controller is as ZCAN 

master, communication ratio is 500K, Can is enabled.(see details in ZBasic). 

If need to modify communication setting, just set value of CANIO_ADDRESS, 

CANIO_ENABLE etc.  

Port0: RS232, as slave, address is 1, VR and Modbus storage are independent; 

Port0: RS485, as slave, address is 1, VR and Modbus storage are independent; 

See details by instruction: SETCOM in ZDevelop. 

After connecting the controller, you can check the model, IP address and running status of the 

currently connected controller by printing the information in the status bar below. You can also 

view the specific content of errors, warnings, and messages through the "Command and Output" 

window. 

 

2.2  Controller Reset 

After connecting controller, click menu bar “Controller” – “Reset the controller” to open below 

window, then click “确定”. Controller will restart after power on, then reconnect to controller. 
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2.3  Lock or Unlock Controller 

Controller lock is used to protect code in controller, under lock status, project can not be loaded 

into controller, code in controller also can’t be accessed, but zar file is allowed to be loaded into 

controller, enable developer to capsulate code in zar file through ZDevelop and send it to customer, 

then customer upgrade controller by loading zar file into controller through independent tool: 

Zardown.exe(for customer use). 

Irreversible algorithm is used for encryption, password can’t be discovered once forgotten. 

Click menu controller>lock controller to set the controller lock password, after lock is done, 

we can’t debug controller anymore unless it is unlocked again by type into right password: 

 
The same we can enter controller unlock page: 

 

2.4  Command / Output 

Command and Output can check controller parameters control axis motion, print procedure 

running result, output procedure errors, etc. print and output function in program is given by 

software developer (through ?, PRINT, WARN, ERROR, TRACE, etc). 

Note: they should be in English format. ERRSWITCH is used to control output of TRACE, 

WARN and ERROR, different values indicate different output modes: 

0: Disable TRACE, WARN and ERROR; 

1: Enable ERROR; 

2: Enable WARN and ERROR; 
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3: Enable TRACE, WARN and ERROR. 

Online command and output window is below: >>: commands input from Command box; 

Capture: Save all Output box information in PC; Clear: Clear all information in Output box.  

 

ERROR information shown in red color as follow: 

 

WARN information shown in yellow color as follow: 

 

Common used print & check instructions: 

?*SET: print axes and system parameters.  

 

?*TASK: print task status, including error task number and lines; 
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?*MAX: print all controller parameters; 

 

max_axis: 64    max axes, including virtual axes. 

max_motor:64   max motor axes  

max_movebuff:4096   max motion buffer of each axis or each axis group 

max_in:27    inputs and max inputs after extended 

max_out:15   outputs and max outputs after extended  

max_ain:0    analog inputs and max analog input after extended 

max_aout:2    analog outputs and max analog outputs after extended 

max_pwm:4   max PWM channels 

max_slot:1    max Bus channels 

max_comport:3   max serial ports 

max_ethport: max Ethernet ports 

max_ethcustom: max self-defined Ethernet ports 

max_ethiport: max Ethernet ports for communication between Zmotion controllers. 

max_flashnum: max FLASH blocks; 

max_flashsize: space of each FLASH block; 

max_nand: max NandFlash space; 

max_nandremain: remaining NandFlash space; 

max_pswitch: max soft position comparers; 

max_file: max files of system 

max_3file:max z3p file of system; 

max_task: max tasks of controller 

max_timer: max timers 

max_loopnest: max internal recycles and selections 

max_callstack: max stack levels called by SUB process 

max_local of one sub: local variables of SUB process 

max_vr: max VR number; 

max_table: max TABLE number; 

max_modbusbit: max MODBUS_BIT number; 

max_modbusreg: max MODBUS_REG number; 

max_var: max variables; (including global and file variables) 

max_array: max array number; (including global and file array) 

max_arrayspace: total array space; 

max_sub:max SUB numbers; 

max_edgescan: max falling or rising edge scanning threads; 
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max_lablelength: max char length of array and variable name; 

max_hmi: max HMI numbers and HMI screen size; 

function support: motion functions supported; 

?*FILE:print file tasks information. 

 

?*SETCOM: print serial ports information 

 

?*BASE: print BASE axes list of present task(valid in firmware version above 140123） 

 

?*array: print all elements of array, if array length is too large, only partial elements can be 

shown; 

 

?*array(n):print one array element. 
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?*parameter name: print this parameter of all axes. 

?*ETHERCAT: print EtherCAT connection status. 

 
Slot 0 contain 1 nodes:devices connected to slot 0 

Lostcount 0-0:lost packets 

Node:NODE serial number of connected devices; 

Status:devive connection status,see ZBasic instruction:NODE_STATUS for reference; 

Manid:manufacturer ID; 

Productid:device ID; 

Axises:max axes of device; 

AL Status:outputs status of device; 

Node_profile:profile setting of device; 

Bindaxis:mapped controller axis number; 

Drive_profile:PDO setting 

Controlword:control word 

Drive_status:device status,see ZBasic instruction:DRIVE_STATUS for reference; 

Drive_mode:device control mode; 

Target:motor position; 

Encode:encoder position. 

?*RTEX: print RTEX connection status. 

 

Slot 0 contain 1 nodes:devices connected to slot 0 

Lostcount 0-0:lost packets 

Node:NODE serial number of connected devices; 

Status:devive connection status,see ZBasic instruction:NODE_STATUS for reference; 

Manid:manufacturer ID; 

Devicetype:device ID; 

Axises:max axes of device; 

AL Status:outputs status of device; 

Bindaxis:mapped controller axis number; 

Drive_profile:PDO setting 

Controlword:control word 

Drive_status:device status,see ZBasic instruction:DRIVE_STATUS for reference; 

Target:motor position; 

Encode:encoder position. 

?*FRAME:print robot arm parameters,valid in firmware 161022 or above 
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?*SLOT:print slot information. 

 

?*PORT: print all ports information. 

 

COM: serial port; 

ETH: Ethernet port; 

ECUSTOM: self-defined net port; 

CONNECT: net port of controller link. 

2.5  Firmware Upgrade 

The firmware upgrade is used to update the existing firmware version of the controller. If the 

current firmware version cannot meet the program running requirements, or some command 

functions are not supported, the firmware needs to be upgraded. 

There are 2 ways to upgrade controller firmware, by independent tool: zfirmdown, or by 

ZDevelop directly. 

By ZDevelop: 

Prepare firmware file first, click menu: Controller > Firmware controller, to enter firmware 

upgrade window. 

 

Click “Browse” to select firmware file, click “Update”, will pop window: Enter ZBIOS?, click 

“Confirm”, then will pop another new window: Connect to controller? Link to controller again. after 
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link with controller is built again, it will enter firmware upgrade window again, which is in ZBIOS 

status, typestring item is shown as “model-ZBIOS”. 

click “update”, process bar will come, firmware upgrade finished after it reach 100%, output 

box will print message: Update firmware to controller Success. 

 

Then, reconnect to controller and check the firmware version number of controller state. 

2.6  Modify IP Address 

Menu bar “Controller” – “Modify IP Address”, below window will appear, now, it shows 

current controller IP, then input new IP address directly. 

 

After modifying, controller and ZDevelop will disconnect, which means they need to make 

connection again. 

2.7  System Time Setting 

Controller time can be set by manual or synchronize with PC system. 
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Chapter III ZDevelop Project 

Project is necessary file which is operated in Zmotion controller, we need to create it in 

Develop, then load it into motion controller. One project contains all logic needed for application 

operation. 

3.1  Project File 

File name of project file with suffix “.zpj”, file in program must be in the same folder as project 

file (namely, bas/plc/hmi file included by zpj file are saved in same folder). 

Click “File”, and select “open project”, added project file (bas/plc/hmi file in this zpj) will open 

automatically, or drag zpj file to ZDevelop so that open directly. 

If only open bas/plc/hmi file, but relative projects are not opened, then program can’t be 

downloaded, which means it can’t run. 

 

3.2  Project Configuration 

Reserved functions 

3.3  Program File 

Zbasic file: programmed in Zbasic, which is the most important language for Zmotion products, 

including almost all main product function concepts, as most recommended language when try to 

develop application through Zmotion controllers, file suffix is “.bas”. 

ZPlc file: programed in ZPlc, a ladder diagram language developed by Zmotion, file suffix is 

“.plc”. 
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ZHmi file: programed in ZHmi, which is developed for Zmotion HMI configuration, file suffix 

is “.hmi” 

3.4  ZAR File 

ZAR file is a kind of encryption file, the suffix is .zar. After project item generated ZAR file, 

code can’t be found. Now, you can download ZAR file into controller, the methods of downloading 

ZAR file refer to chapter IV. 

3.5  Library File 

Library file is generated from “compile as Lib” and is saved for program protection, program 

won’t be modified. Library file’s name with suffix “.zlb”, the methods of compiling Lib file refer to 

Chapter IV. 
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Chapter IV Program Edit 

ZDevelop integrates program edit and program debug, which means it is easy to use. 

4.1  Quick Edit 

ZDevelop provides a very convenient program editting environment, many shortcut buttons 

can be used. 

1. Tool bar: 

 

When the mouse is placed on the button, the name of each button is automatically prompted. 

 

New: new build a file, basic/plc/hmi can be selected. (Ctrl + N) 

Open: open file, basic/plc/hmi can be selected. (Ctrl + O) 

Save: save the modification of current file. (Ctrl + S) 

Save All: save modification of all files. 

 

Connect: connect to PC. (Ctrl + Alt + C) 

Disconnect: disconnect to PC. (Ctrl + Alt + D) 

Down Ram: download the current program into controller, don’t support power failure storage. 

Down Rom: download the current program into controller, support power failure storage. 

 

Toggle Scope Window: open oscilloscope 

EtherError_Tool: entrance of bus node diagnose tool, open below window, current node 

information and communication diagnose can be checked. 
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Cut (Ctrl + X) / Copy (Ctrl + C) / Paste (Ctrl + V) / Print (Ctrl + P) program 

“Print” is only valid in Basic program and PLC statement list program, it doesn’t support HMI 

and PLC. 

 

Search (Shift + F4): search in whole project, and the result will show in “Find” window. 

 

RO (read only): under this status, program can’t be modified. After starting RO function, the 

mark will become bule color. If you still input, below hint will appear. (HMI doesn’t have RO 

function) 
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Go back: it will go to former modification place. 

Go forward: it will go to next modification place. 

 

Debug tool: it is valid in debug state, please see Program Debug. 

 

Emerge stop: emerge stop program and motions of all axes. 

2. Control tool bar: 

 

The HMI component shortcut button is only valid under HMI programming. The last hand 

button  is the button to open the xplcscreen touch screen simulation tool. 

First download the program to the controller or simulator, and then click the hand button, the 

following window will pop up, select the IP of the controller in the small window and connect it, 

and the HMI configuration interface that has been downloaded to the controller/simulator will 

display. 

 

After connecting successfully: 
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3. HMI tool bar: 

 

The left part is HMI component alignment button, the right part is HMI language switch and 

status switch button. 

4. Ladder of Diagram tool: 

 

PLC ladder diagram shortcut input button. 

4.2  ZBasic 

There are quick tips when type instruction: 

 

It provides grammar highlight function. 

Instructions, variables parameters, comment and others show in different colors. 

The line below the IF command is a snap line, which can be canceled by using the menu bar 

"View" - "Indent Line". The "Auto Linefeed" function can make the program display automatically 

wrap according to the size of the current program editing window. 
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“Add Comment” makes program block into comment part quickly, “Del Comment” makes 

comment into program. 

Operation: select one certain program in Basic, click “Edit” – “Add Comment”, then selected 

program will become comment. Also, select one certain comment, click “Edit” – “Del comment”, 

then selected comment will become program. 

 

Menu “Edit” – “Insert Tab” / “Del Tab” function is used to control the program indent. Below 

is the “Del Tab” operation result for whole IF cycle command, operate once, and indent is fixed. 
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Menu “Edit” – “Find”, find in project. 

 

Menu “Edit” – “Replace”, find and replace in project. 

 

4.3  ZPLC 

In ZPLC, there are 2 programming modes: ladder diagram and instruction list, these two modes 

can switch to each other freely.  

Note: no distinction between capital and lower letters when programming in instruction list 

mode. 

Menu “Edit” – “TolL” / “ToLad”   

TolL: convert to instruction list 

ToLad: convert to ladder diagram program 

⚫ Ladder diagram: it is convenient and east to observe, it needs programmers are familiar 

with PLC instructions 
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⚫ Instruction list： 

 

Program Edit: 

Click shortcut labels to insert relevant functions: 

 

 

Double-click in the corresponding cell or directly enter the command, you can also achieve 

shortcut input. You can enter commands or modify parameters. Click "OK" to save the modification 

results, click "Cancel" to close the shortcut input box, and click "Help" to open the help document. 
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Click “…” label in quick insert box to open PLC instructions input box, which enables 

instruction quick selection and parameter setting.  

 

Remember to add END in the end, or it can’t run. 

Use “EXE @” command to call Basic in PLC, PLC and Basic have some shared variables, 

please see PLC program manuals for details. 

Debug  

After entering debug mode, some signs will appear to indicate status: green-on, red-break, 

register present value also will show above.   

 

Note: interruption debug is not supported in ladder diagram mode, but it is supported under 

instruction list mode. 
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Write Value 

In debug mode, select target cell and right click to enter menu: write data in this page, we can 

edit M(bit value) or D(word value). 

 

Write value window is below: it only shows the current selected register. 

 

Add comments 

There are three ways to add comments, as follow: 

1. by instruction “//” 

This is usually used to explain function block in the front of the code, and it consumes one line. 
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2. By right click menu function: notes edit 

This function is used to explain soft elements under ladder diagram program. 

Note edit method: select target soft element, right click to enter “note edit” page.  

 

When there is comment editing window, double click “left button” below the comment, then 

input comment, click OK. 

 

Comments can be hided or displayed by disable or enable right click menu item: notes show. 

3. By view note window 

Click menu: View> notes to enter view note window, it is usually used to add comments of 

PLC elements.  

“system notes” is used for special relay M and special register D, quick add comments to all 

elements.  

“project notes” is used for input register definition and comments add, project notes can be 

imported or exported.  
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4.4  ZHMI 

HMI programming is used to customize the display on the display screen, and touch to perform 

related operations. Open the configuration "component" to quickly select the input object and 

improve the programming efficiency. 

Common functions of elements: call sub functions, open / close configuration window, bind 

register, show text / graphic, etc. Different functions have differences, please see “ZHMI Program 

Manual” for details. 

 

Menu “Edit” – “Hmi Setting”, it must set if run HMI file, Hmi system configuration is in 

right window, please see it. 

 

Resolution is set according to display screen size, normally, it is 800*480 for 7-inch screen. 

Initialization function is only called once after power on, it is defined in Basic, and function 
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must be global function (GLOBAL). 

The initialization function or periodic function is not required to be set. The way the HMI calls 

the Basic function also includes the drawing function or refresh function of the custom component, 

and the action “call sub” of the component. 

In the configuration view, the right-click menu "Property" can quickly edit the window display. 

The pop-up property window is related to the position of the mouse. Place the mouse on the 

component and right-click the property window as shown in the left figure. Place the mouse on the 

blank space and right-click. The Property window is shown on the right. 

                

Component right click “Property”                   background right click “Property” 

Property description of Bit status switch (BitSwitch): 

Property  Function  Description  

Object number / / 

Object name / / 

Layer Select component display 

layer 

TopLayer: on the surface, it shows the   

most external layer, and covers 

below components. 

MidLayer: the middle layer 

BottomLayer: the bottom layer (default)  

IfValid Select component displays 

or not 

Default is Ture, when select False, the 

component does not show and no 

functions 

Valid Control Control component display 

or not through register 

Default is False, True means it is 

controlled by register. 

Safe time (ms) The leaset button time Unit is ms. 

Device NO. Device number Default is local 

Regtype Select register type Select from the list 

Regnumber Select register number It does not show when register value is 0, 

it is used when not 0. 

Use PictureLib BackPicture / Back Picture Select from picture library or backgroud 
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Background picture Select background picture After select background picture for picture 

source, then add 

If Draw edge Select if draw edge Default is False 

If MakePic Element into picture Default is False 

Text Lib  The name of text library If empty, indicates the use of a text label 

Format text 0 / 1  Open the Format Text 

Settings window to set the 

text to be displayed by the 

component 

Default is text 0, button it, it will become 

text 1 

Action Motion to be executed 

when button 

 

Action when up Select execution action 

when press or release. 

Default False is the action when pressed, 

True is the action when released 

Action operation 

window 

Select window numer be 

operated 

Select from the window list 

Follow main 

window close 

Sub window close together 

with main window 

Default is False 

Action data Write assigned value for 

register after pressing 

/ 

Action function 

name 

SUB function to be called 

after pressing 

Select global SUB function of Basic 

Virtual button code Select virtual button codes Default is not to select 

Top  Vertical starting position Not to execeed vertical resolution 

Left Horizontal starting position Not to execeed Horizonical resolution 

Width The width of element / 

Height  The height of element / 

Steps for running new-built HMI file 

1. Build HMI file, add autom run task number. 

2. Open “HMI setting” window, set screen resolution, start dispalyed window, etc. 

3. Edit HMI file, build a new window, add component, and open relative “Property” window 

and element function. 

4. Build new Basic file, edit Basic subfucntion content to be called by HMI component. 

5. Add initialization function and period function in “HMI Setting”, and add subfunction 

name in component motion place of Basic program that is going to be called. 

6. Connect to controller or simulator, download the program. If there is no real object, 

connect to xplc screen for simulation. 

HMI Program Example: bind with register 

1. Build a new HMI file, and add auto run task number. 

2. Add status switch component in start IO window. 

3. Open component “Property” window and select register type and number, “Action” select 

“Reset Bit”, which means assign binded register as 0. 

4. Download program into controller or simulator, press the component in main page for 

checking effects. 



                                          ZDevelop User Manual Version V3.10.04 

37 

 

 

Achieved effect: 

When press the object, MODBUS_BIT(0) = 0, if select release action, which means first to 

press it, then release it, and MODBUS(0) still equals to 0. 

HMI Program Example: Call SUB function 

1. Build new HMI file, and add auto run task number. 

2. Add status display object in Bit switch window. 

3. New build Basic file, no need to set auto run task number, and edit global SUB subfucntion 

to be called in Basic. 

4. Open object “Property” window, and select editted SUB subfunction name in “click 

calling function”. 

5. Download program into controller or simulator, press the component in main page for 

checking effects. 
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Achieved effect: 

When object is pressed, call SUB subfunction of Basic, call function once when press once. 

More HMI routines can be downloaded from ZMOTION webiste. 

4.5  Right Click Menu 

Right click menu functions differ in different program modes: ZBasic, ZPLC and ZHMI. There 

are some important functions need to keep in mind, which will increase programming efficiency. 

Go to define of—select ZBasic keyword, enter right click menu to find source of keyword. 

Toggle breakpoint—add breakpoint in program, help to debug; 

Add to watch—add variables or values to watch window; 

Find/Replace—find or replace letters. 

                 

Right Click in ZBasic                       Right Click in ZPLC 

4.6  Bookmark 

In Edit menu, we can select bookmark functions: Toggle bookmark, next bookmark, last 

bookmark, edit bookmarks. 
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In ZBasic, green label will appear in front of code line if bookmark added: 

 

In ZPLC, letter “M” will appear in front of code line if bookmark added: 

 

4.7  File View 

On left side of ZDevelop, it is FileVIew page, file numbers, type, and task number are all 

shown here. Double click file item to open and edit file, right click file item to open setting window 

for more configuration.  

 

4.8  SUB View 

On left side of ZDevelop, click “Sub View” to check all Sub functions in project, double click 

sub item to jump to sub definition line.  
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4.9  HMI View 

On left side of ZDevelop, click “HMI View” to check all windows and elements in HMI file. 

Double click item to open property setting window: Feature 
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Chapter V Run Program 

5.1  Load Program (RAM/ROM) 

In ZDevelop, program must be downloaded into controller, and must build project, then it 

can download. 

 
Download RAM: load project into ram, run immediately, it will lose after power off. 

Download ROM: load project into rom, run immediately, it supports power failure storage. 

 this function is not supported in ZMC00x series. 

If project size is too large, click menu: Debug>Compile all, to compile code first, then load 

project into controller, in this way, project load time will be shortened. 

 

When download, you can open oscilloscope to get motion curve and other changes. 

5.2  Auto Run 

In a project, at least one auto run number should be set for one file. After load project into 

controller, project files with auto run number will run controller automatically, if auto run number 

was not set in any project file, project can not be executed in controller, error information will come: 

WARN: no program set autorun. 

Set project file autorun number in “File View” page. Usually only one autorun number is set, 

other tasks can be called be instruction: Runtask, Run. Maximum tasks supported in controller is 

shown in “controller state” page in ZDevelop.  

 

5.3  Load ZAR 

In ZDevelop, developer can convert project into encrypted ZAR file, which can’t be opened 

and edited again, and Zar file also can be bound with Controller ID (controller unique sequence 

number, which can be checked through “Controller status” or SERIAL_NUMBER) to let this Zar 
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file only be valid after loaded into unique controller whose ID matches its bound controller. 

Through menu bar “Project”, select “Make Zarfile”. 

 

Make Zarfile: 

After debugged program, you can download ZAR file after setting password, which needs to 

use APP_PASS instruction to write password into program for correction. 

If select it is bound with controller ID, it will correct controller ID automatically when 

download ZAR program, it will be downloaded successfully only when their ID are consistent.  

End user downloads independent tool software “ZarDown”. Usage steps are same as ZDevelop. 

 

Download Zarfile: 

Click “Download Zarfile”, then select from system disk. 

Or use FILE command “LOAD_ZAR” function to upload ZAR file in U disk. 

5.4  Compile Lib 

This function belongs to program encryption, same as ZAR Download. It can compile a 

program file as one library file to save, which is convenient to protect program. File name of library 

file with suffix “. zlb”, library file only shows global SUB definition. 

After debugged, click menu “File” – “Compile Lib”, it will compile all project files as one 

library file. 

 

After compile, add Lib into project again, click right button of mouse in left project window 

of software, please see the left. Then Lib file is added, see the right picture. 
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Then, delete the original Lib file, set auto run task number is 0, redownload the Lib file into 

controller. 

 

Open the program in Lib format at this time, you can see the declaration of the program body 

definition, only the global definition can be viewed, the local variable definition and the specific 

process of the SUB sub-function cannot be seen. 

5.5  Compare Project 

Click menu: Controller > Compare Project, to compare current program projects between PC 

and Controller. 

If file is same, it will show “Yes”, if not, then show “No”. 

 

Note: for enryption purpose, code in controller can not be uploaded. 
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Chapter VI Controller Windows 

6.1  File/Process/Configuration Window 

File window, process window, and configuration window refer to Chapter IV. 

6.2  Command and Output Window 

Command and Output window refers to Chapter II. 

6.3  Find Result Window 

“Find” window is used to quickly find matched keywords, the result searched from whole 

project file will show in “result window”. 

Find method: menu “Edit” – “Find in Project”, open below window: 

 

Researched result is below, it shows filename, line number and content, click relative line, 

program position can be located. 

 

6.4  Axis Parameter Window 

Click menu View>Axis Parameter to open axis parameters page.  

In this page, we can select axes and parameters need to check. Axis parameters include speed, 

acceleration, Atype, etc, all parameter explanations are mentioned in ZBasic in details, please check 

in ZBasic. Below changeable parameters can be modified directly through double-click, but it is 

invalid for read only parameter. 
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Parameter  Description  

ATYPE Axis type, 0-virtual axis, 1- pulse output, 3- orthogonal encoder 

input, 65-EtherCAT CSP mode 

UNITS Pulse equivalent means the pulse numbers are sent in one unit, 

which supports 5-bit decimal precision. 

ACCEL/DECEL Axis acceleration/deceleration, unit is units/s/s, when multi-axis 

moves, acceleration of axis group interpolation is master axis 

combined vector acceleration/ master axis combined vector 

deceleration. When DECEL is not set, it is ACCEL by default. 

SPEED Axis speed, unit is units/s. when multi axes move, it is the main axis 

vector speed as axis group interpolation. 

CREEP The creep speed when axis homing, it is used for origin searching, 

unit is units/s. 

LSPEED Axis starting speed, also it is stopping speed, default is 0, unit is 

units/s. when in multi-axis motion, it is joint vector speed of axis-

group interpolation. It can be set not as 0 for achieving efficiency, 

but can’t be oversize. 

MERGE When it is ON, in the front and back buffer motions are connected 

together, speed keeps, which is used for continuous interpolation. 

SRAMP S curve setting when in acceleration and deceleration motion, unit 

is ms. It is time for axis-group to compound vector curve in multi 

axes motion. 

DPOS Expected coordinate position of axis, or target position, unit is units. 

MPOS Measured feedback position of axis, or actual position, unit is units. 
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ENDMOVE The end target absolute position of current motion, unit is units. 

FS_LIMIT Axis forward software position limit. unit is units. If axis motion 

exceeds the boundary position, it will stop and report error 

“FSOFT”. 

RS_LIMIT Axis reverse software position limit. unit is units. If axis motion 

exceeds the boundary position, it will stop and report error 

“RSOFT”. 

DATUM_IN Input number related to origin switch position, -1 means invalid. 

FWD_IN/REV_IN Input number related to forward/reverse hardware position limit 

switch, -1 means invalid. When controller position limit signal took 

effect, axis will stop immediately, stop deceleration is FAST_DEC. 

Normally, FAST_DEC is set to be 10 multiples of DECEL.  

IDLE Axis current motion status judgement, it will return 0 when in 

motion, it will return -1 when motion ends, only for read. 

LOADED When there is no motion instructions to be buffered in motion 

buffer, it will return TRUE, or will return FALSE, only for read. 

MSPEED Axis actual speed form measured feedback, unit is units/s. MSPEED 

is differential value from MPOS, only for read. 

MTYPE/NTYPE Current running motion instruction type MTYPE/the first buffered 

motion instruction type NTYPE. When in joint interpolation, it is 

motion instruction type for slave axis to return to vector master axis. 

Only for read. 

REMAIN Return uncompleted distance of axis current motion MTYPE, unit 

is units. Only for read. 

VECTOR_BUFFEREED Return uncompleted distance of axis current motion and buffer 

motion, unit is units. It is compound vector distance for multi-axis 

interpolation, unit is units. 

VP_SPEED Return planned speed of current motion, unit is units/s. when in 

multi-axis motion, axis-group returns to compound speed of 

interpolation motion, not component velocity. If it is not master axis, 

it returns to related compound vector speed of axis and relative 

component velocity, the same effect as MSPEED, only for read. 

AXISSTATUS Check all bits’ status, such as, forward/reverse hardware position 

limit, forward/reverse software position limit, axis running status, 

etc. only for read. 

MOVE_MARK MARK label number of motion instruction, this is written into 

motion buffer together with motion instructions. Each motion 

command is called, MOVE_MARK will add one automatically. If 

need to force to assign MOVE_MARK, it needs to be set once 

before motion. It can pause in different MARK boundaries through 

MOVE_PAUSE. 

MOVE_CURMARK Return MOVE_MARK label number of current axis which is 

running. 

More parameters can be referred through Axis parameter and axis status instruction in 
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ZMOTION BASIC PROGRAM MANUALS. 

Click “Axis Select”, axis can be monitored. 

 

Click “Parameter Select”, below window will appear, axis parameter can be customized for 

monitor, but it is not recommended to set too many, avoid affecting refresh efficiency. 

 

6.5  Manual Motion Window 

Click menu View>Manual to enter Manual page, in this page, user can operate connected 

motor by manual. User is able to select axis, set axis parameters: Atype, Units, Accel, Decel, Speed. 

Left parameters can be modified real-time, press “LeftMove” / “RightMove” (not loosen), 

motor will continue to move in left / right, the button is released, the motion will stop.  

“DPOS” shows current DPOS motion distance (unit is units).  
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When fill “Distance”, select “Absolute”, the motor will move to absolute distance. When 

“Absolute” is not selected, motor moves in relative distance. 

Axis number can be selected from the list. 

“MPOS” / “IDLE” / “AXISSTATUS” these 3 parameters are only for read, they can’t be 

modified.  

“Stop” is pressed, axis motion will stop immediately. 

 

6.6  Oscilloscope Window 

Oscilloscope is extremely important of program debugging and running. It is used to transfer 

signals that can’t be seen by naked eyes into graphics, so it is convenient to analyze change processes 

of all kinds of signals. Oscilloscope shows controller internal data in graph, it can display different 

signals, like, axis parameter, axis status, etc. “View” – “Scope”, then oscilloscope window can be 

opened, or click the shortcut button . 

 

The oscilloscope must be triggered to successfully sample. Turn on the oscilloscope, click 

"Start Scope" after setting the relevant parameters. Also, it could be manually triggered sampling, 

or add the "TRIGGER" instruction to the program to automatically trigger the oscilloscope sampling. 

Oscilloscope basic setting button function: 

Config: open oscilloscope configuration window, set relevant parameters 
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Start Scope: start oscilloscope (but not to trigger oscilloscope capture) 

Stop: stop oscilloscope capture 

XY mode: when checked, switch to the XY plane to display the interpolated composite track of the 

two axes. 

<<: press to hide the channel name and peak value, and only display the channel number. 

Trigger: manually trigger oscilloscope capture button (use TIGGER instruction to trigger 

automatically) 

Follow: After the following is enabled, the horizontal axis automatically moves to the real-time 

sampling point and follows the waveform display. 

Show: choose whether the present channel curve shows or not 

Index: select the data source number that needs to be captured, such as, axis number, digital IO 

number, analog IO number, TABLE number, VR number, MODUBUS number, etc. 

Source: select captured data type 

Offset: Set the offset of the vertical axis of the waveform. 

Xscale: The scale of one grid on the vertical axis. 

Yscale: The scale of one grid on the horizontal axis. 

If sets oscilloscope parameters, like, axis number, data source and start oscilloscope configuration 

window, it should stop firstly, then to do configure. 

 

Chanel Num: channel total numbers to be sampled. 

Depth: total sampling numbers, the depth is bigger, the sampling ranger is bigger. 

Space: sampling time space. The unit is system cycle, which is related to the firmware version of 

the controller. Generally, default is 1ms, and see it through SERVO_PERIOD instruction. Usually, 

the smaller the space, the more accurate the sampled data, and the larger the amount of data per unit 

time. 

TABLE Pos: Set the position where the captured data is stored. Generally, the space at the end of 

the TABLE data is automatically used by default, and you can also customize the configuration, but 

be careful not to overlap with the TABLE data area used by the program when setting. 

BackCor/Channel Color: set background and the color related to each channel’s waveform. 

ShowType: there are two curve types to be chosen, point and line. Abnormal data is easily found 

out by Line. 
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Continuous acquisition: when the continuous acquisition is not enabled, the sampling will stop when 

the sampling depth is reached. After the continuous acquisition is enabled, the oscilloscope will 

continue to sample. 

Export parameters: export oscilloscope parameters. 

Import and export data: 

Import：data can be imported when oscilloscope stops, and if it is imported successfully, sampling 

waveform can reappear. 

The method of importing sampling data: click “Import”, import data file that should be the former 

file type exported from oscilloscope, then open it. 

Export: export parameters, including oscilloscope parameter configuration, data type of each 

channel and each sampling point’s data. 

The method of exporting data: click “Export parameters” in “Scope Config”, then start scope. After 

sampling, click “Export”, and select folder to store oscilloscope data, the exported data is text file. 

Oscilloscope Sampling Method: 

➢ Open project, connect to controller or simulator, then open the oscilloscope window (note: first, 

connect to controller or simulator, then operate the oscilloscope window). 

➢ Click “Scope Config” in oscilloscope window, select sampling channel numbers, sampling 

depth, sampling space, sampling data TABLE stored position (generally the end position of 

TABLE array will be used automatically) and sampling type, etc. Then, click “OK” for saving 

this configuration. 

➢ Select sampling Index and Source, click “Start Scope”. 

➢ Download program into controller, the program should include TRIGGER, the trigger 

oscilloscope sampling automatically instruction. Now, it starts sampling and shows different 

data source’s waveforms. It can adjust Show Scale and Wave Offset, this is for observing 

different waveforms. 

If the waveform accuracy is not high or the display is incomplete, click the "Stop" button and then 

open the "Scope Config", and adjust the sampling space and sampling depth, and perform the above 

sampling process again. 

If the sampling time is long, start “Continuous acquisition” function. 

Precautions for Using Oscilloscope: 

Oscilloscope sampling time calculation: 

 For example, depth: 1000, space: 5 

 If system cycle is SERVO_PERIOD=1000, which means 1ms trajectory planning cycle. Space 

5 means sampling one data point per 5ms. Total sampling data number is 10000, so sampling 

time length is 50s. 

TABLE data end storage space calculation: 

 Set the position where the captured data is stored. Generally, the space at the end of the TABLE 

data is automatically used by default, now starting space address is calculated automatically 

according to captured data space. 

 Calculation method: captured data space = channel numbers * depth 
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 For example, if TABLE space of controller is 320000, there are 4 sampling channels, depth is 

30000, each sampling point occupies one TABLE, so it will occupy 4*30000=120000 TABLE 

positions. 320000-120000=200000, which means starting position of TABLE is 200000. 

 The position for storing data also can be self-defined, if according to above channel number 

and depth, TABLE starting space can’t exceed 200000 when it is self-defined, otherwise, it 

can’t be configured, please see below picture: 

 
 The space occupied by the oscilloscope sample data should not overlap with the TABLE data 

area used by the program. 

 Controller TABLE space can be read through TSIZE instruction, check “Controller Status” or 

input ?*max to print and check. 

Continuous acquisition: 

 When continuous acquisition is not selected, the oscilloscope automatically stops sampling 

when the sampling depth is reached. 

 First select “Continuous acquisition” in “Scope Config”, then start oscilloscope, it will 

continue to sampling after triggered, and sampling even if it reached the depth. It will stop until 

press “Stop” button manually. 

 All waveforms and captured data from continuous acquisition can be exported. 

Oscilloscope Usage Routine:  

Example 1: Continuous trajectory look-ahead application 

RAPIDSTOP(2) 

WAIT IDLE(0) 

WAIT IDLE(1) 

BASE(0,1) 

DPOS=0,0 

ATYPE=1,1 

UNITS=100,100  

SPEED=100,100  

ACCEL=1000,1000  

DECEL=1000,1000  

SRAMP=100,100  

MERGE=ON  
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CORNER_MODE=2                          ′start corner deceleration 

DECEL_ANGLE = 15 * (PI/180)                ′set angle of starting deceleration 

STOP_ANGLE = 45 * (PI/180)                  ′set angle of ending deceleration 

FORCE_SPEED=100 TRIGGER                ′trigger oscilloscope automatically 

MOVE(100,100) 

MOVECIRC(200,0,100,0,1)  ′Radius 100 draw a semi-circle clockwise, end coordinates (300,100) 

Speed and position curve of sampling axis 0 and axis 1:  

 

Two-axis interpolation synthetic trajectory in XY mode: 

 

Example 2: PSO position synchronization output, output OP signal when arriving comparison 

point 
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RAPIDSTOP(2)  

WAIT IDLE(0) 

BASE(0)  

DPOS=0 

MPOS=0 

ATYPE=1 

UNITS=100 

SPEED=100 

ACCEL=1000 

DECEL=1000 

OP(0,OFF) 

TABLE(0,50,100,150,200)                     ′coordinate of comparison point 

HW_PSWITCH2(2)                          ′stop and delete incomplete comparison points  

HW_PSWITCH2(1, 0, 1, 0, 3,1)                 ′compare 4 points, operate output 0 

TRIGGER                                  ′trigger oscilloscope automatically 

MOVE(300) 

 

Example 3: Electronic Cam Application 

RAPIDSTOP(2)  

WAIT IDLE(0) 
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BASE(0)                                   ′select axis 0 

ATYPE=1                                  ′pulse directional step or servo 

DPOS = 0  

UNITS = 100                                ′pulse equivalent 

SPEED = 200  

ACCEL = 2000  

DECEL = 2000 

′Calculate TABLE data 

DIM deg, rad, x, stepdeg 

stepdeg = 2        ′use this to modify line number, line is more, speed is more stable 

FOR deg = 0 TO 360 STEP stepdeg 

rad = deg * 2 * PI/360                     ′convert to radian 

X = deg * 25 + 10000 * (1-COS (rad))        ′calculate offset of each small segment 

TABLE (deg/stepdeg, X)                   ′store TABEL 

TRACE deg/stepdeg, X 

NEXT deg 

TRIGGER                                   ′trigger oscilloscope sampling 

WHILE 1                                    ′cycle motion 

CAM (0, 360/stepdeg, 0.1, 300)                  ′the virtual follow length is 300 

WAIT UNTIL IDLE                           ′wait until motion stops 

END 

Motion trajectory: total time of each cam instruction = distance / speed = 300/200 = 1.5s 

 

6.7  Input IO Window 

Click menu View>In to enter input state page, in this page, click “IO select” button to select 

Inputs need to check, click “refresh” button to view special functions attached to inputs.   
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“Special” is to show some special signal inputs: homing, position limit, alarm, etc. 

In some situation, we will use ZBasic instruction: INVERT_IN to reverse input signal. (it needs 

to reverse signal after ZMC Series special input definition, but no need for ECI Series, because 

ZMC Series is valid in OFF.) normally, input state is green when signal comes; after setting 

“INVERT_IN”, invert state turn to green, input state is gray when normally open signal comes. 

Check “INVERT_IN” in ZBasic for details.   

For example: JOG motion 

 

IN0, IN1, IN5, IN6, IN7 and IN8 all defined to inverse input signals (ZMC Series motion 

controller default OFF is valid, so it will inverse, ECI won’t), only IN5 has input, others have no 

input. 

Click “IO Select”, it will show input IN, one group has 16 inputs, see below. Click “Refresh”, 

it will refresh each IO status and special function definitions. 
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6.8  Output IO Window 

Click menu View>Op to open output status page. 

Press the button, OP can be operated, please see below, OP 1 and OP 2 are opened, others are 

still closed. 

When link with simulator, output IO status cam be checked through output and monitor 

window, but it only shows number 0-11 status. 

“IO Select” is used to select output to be displayed, each group has 16 outputs. The output 

status can be switched through clicking output directly. 

 

6.9  Task / Monitor Window 

    Task and monitor windows belong to program debug, these two windows can be used to view 

task running situation and adding monitor project, Task and Monitor window can be referred to 

Chapter VII. 

6.10 Register Window 

Click menu View>Register to open register page, in this page, different kinds of register can 

be viewed directly, including modbus, VR, table, input, output etc. Note: this function only 

available in controllers that support PLC function. 

How to use: Select the type, starting number, and number of the register to be read, and then 

click "Read" to display the data in the window. Be careful not to read more than the register range, 

otherwise it will prompt an error. The refresh function is convenient to automatically collect and 

display the change of register value in real time, otherwise, you need to click again to read the value 

change of the register. Click "Import"/"Export" to quickly upload/download register data. 

Export data is convenient for customers to export some registers that they care about to text to 

save. 

Importing data allows customers to directly change the saved data of the concerned part into 

the controller. 
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Register Type: 

X(IN): input relay, receive external signals, related to IN; 

Y(OP): output relay, drive external load, related to OP; 

S: state relay, control work steps; 

M: auxiliary relay, can’t drive external load, related to MODBUS_BIT; 

D(MODBUS_REG):16 bits integer register, Modbus area data, related to MODBUS_REG 

D(MODBUS_LONG):32 bits integer register, Modbus area data, related to MODBUS_LONG 

D(MODBUS_IEEE):32 bits float register, Modbus area data, related to MODBUS_IEEE 

D(MODBUS_STRING):1 byte character string register, Modbus area data, related to 

MODBUS_STRING 

AIN: analog input 

AOUT: analog output 

DT(TABLE):32 bits float register, related to TABLE; 

V: index register,16 bits; 

Z: index register,16 bits; 

T: time, unit is ms; 

C: Counter; 

VR: retentive register,32 bits float; 

VR_INT: retentive register,32 bits integer. 

Exported data example: 
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6.11 Graphic Window 

Click “View” – “Register”, the graphic window can be opened. Use this window to view visual 

images in a machine vision development environment. The image window can only be used 

normally after the image is captured. It can be switched between the display of all visual images 

and the display of visual latched channel images. 

Visual image can select all the pictures under the current project to display, including the 

collected images and processed images. 

 

Before displaying the image of the visual latch, you need to select the latch channel number 

first, and then display the image of the current latch channel. When the current latch channel is 

empty, there is no image. 
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6.12 AD/DA Window 

Click menu View>AD/DA to view Ads or DAs status of controller.  

 

6.13 Help Window 

Click “View” – “Help”, the window opens. 

Select instructions you want to check, press F1 or click the instruction, help documents will be 

opened quickly. 

 



                                          ZDevelop User Manual Version V3.10.04 

60 

 

6.14 Notes Window 

Click “View” – “Notes”. 

System Notes: check the function of register that has been noted by system. 

Project Notes: add register and relative note content. 

 

6.15 Cross Reference Table 

Click menu View>Cross Reference Table to view used registers information, double click 

register label to skip to its position in program. This table is suitable for PLC programming. 

 

6.16 Register Usage List 

Click menu View>Register Usage List to view registers use status. 

Double left click gray area of label, Cross Reference Table of this label will pop; 

Double left click blank area of label to add comments. 
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6.17 Fond View 

Click “View” – “Fond”. 

User can modify default fond, size, color, etc. 

 

6.18 Custom View 

Click menu View>Custom to set ZDevelop display style, also displayed parameters can be set 

here.  
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Chapter VII Debug 

7.1  Enter Debug 

Click menu Debug>Start/Stop Debug to enter debug mode, choose right mode to start.   

 

Down ram again: load project to ram again and start to debug, not saved when power off. 

Down rom again: load project to rom again and start to debug, support power failure storage. 

No download, Reset: restart controller again and run program that has been downloaded, open 

task window to show current operation status.  

Attach to current: debug current operating project, this program is not downloaded, only open 

task window to show current operation status. 

When errors come in operating project, ZDevelop will show error information, double-click 

the error information, it will locate program position, which means take it for reference to help 

debugging. If there is no error information showing, we can also view errors by typing in 

command:?*task, or open “Troubleshooting” window,. 

Take below routine as example: 

RAPIDSTOP(2)  

WAIT IDLE(0)  

WAIT IDLE(1)           ′select axis 0, axis 1 

ATYPE=1,1  

UNITS=100,100  

SPEED=100,100           ′motion speed 

ACCEL=1000,1000  

DECEL=1000,1000  

SRAMP=100,100          ′S curve 

MERGE=ON              ′open continuous interpolation 

TRIGGER                ′trigger oscilloscope automatically 

DPOS=100,0              ′coordinate offset 

MOVE(-50,100)           ′relative motion 1 

MOVE(-100,0)            ′relative motion 2 
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MOVE(-50,-100)           ′relative motion 3 

MOVE(50,-100)            ′relative motion 4 

MOVE(100,0)              ′relative motion 5 

MOVE(50,100)             ′relative motion 6 

END 

Command and output window prints line 16 of interpolation file appears grammar error, 

error is reported, which means program can’t be downloaded into controller. After solving the 

problem, redownload into program. 

    Also, error information can be checked through “Troubleshooting” window. 

7.2  Debug Tool 

Debug tool bar is only valid in debug mode. 

 

Reset: execute from the start 

Run (F5): continue to run or pause 

Step into (F11): run into program 

Step over (F10): run to next program 

Step out (Shift + F11): jump out SUB subprogram operation 

Run to (Ctrl + F10): run to assigned line 

Toggle breakpoint (F9): set breakpoint, first click to set, second click to cancel. 

Emerge Stop: stop program and motion of all axes compulsively. 

Note: 

1.in debug mode, when procedure in ZDevelop is not same as in Controller, debug indicating line 

will offset. To avoid errors, do upgrade controller procedure if there is modification in ZDevelop 

procedure. 

2.When click “pause”, motion in buffers will not stop.   

7.3  Task Window 

Click menu View>Task to open task window. Or click “Debug” – “Start/Stop Debug” to call 

task and watch window. 

Please note task and watch window only can be opened under debug mode. 

        

Controller supports multi-task running, and the details can be checked when program is in 

motion. Below example is single-task, the max tasks to be supported can be viewed in “Controller 

Status” – “Tasked”. 
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Controller supports multi-task running, after entering debug mode, “View” – “Task” can check 

each task’s specific status. Below example is single task, the task number is 0, status is Running, 

and executed file is Basic1.Bas, executed line number is line:19. 

 

Task window consists of three areas: 

Task tracing: view all tasks status in operating project. 

Stack tracing: when SUB process is called, its status and local variables will be saved in stack. 

We can view these parameters in stack then.  

Local variables: all variables defined by “Local” or input parameters through calling SUB 

process can be viewed here.   

(note: the same task has different local variables of different stakes, even though their names are 

the same; stake’s layer is limited, normally, stake called by subprogram is 8 levels, be careful to 

use recursion structure.) 

 

7.4 Watch Window 

Click View>Watch to open Watch window, in watch window, we can add global or modular 

variables, registers, IOs, valid expressions, etc. Then, trace the values. 

Two ways to add variables to watch window: 

1.Select variables, registers, expression in code, open right click menu to add them to watch 

window. 

2.In watch window, double click blank areas under “Watch Name” item to add or modify 

variables need to watch. 

Note: Local variables can’t be traced in Watch Window, need to trace in task window. Please 

see below, var3 is local variable, Watch window can’t get the value.  
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7.5  Breakpoint 

We can add breakpoint in program, to find out execution of every program step execution on 

registers, variables, array etc. F9 is shortcut for breakpoint add and delete. Or “Debug” – 

“Toggle/Edit Breakpoint”, several breakpoints can be added. “Debug” – “Clear All breakpoints” is 

used to clear all breakpoints in project file once. 

After adding breakpoints, program will stop in breakpoint position. Now, instruction in 

breakpoint line has not been executed, it won’t influence scanned program. 

 

When program stops at breakpoint, we can execute forward by step by clicking F11, each click 

program will execute one step forward.  

If breakpoint is set in the cycle, then next run to breakpoint position again, program still will 

stop. 
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Click menu Debug>Edit Breakpoints to enter Edit Breakpoint page, here user can edit all 

breakpoint, such as, to remove one or multi breakpoints, double click breakpoint label to skip to its 

position in program.  

 

When debug is finished, please clear all breakpoints before load program into controller again, 

or errors will come: Warn file:"Basic1.BAS" line:11 task:0, Paused. 

7.6  Troubleshooting 

Click menu Debug>Troubleshooting to view check errors in tasks. User can check controller 

firmware or hardware version and date, task operation status, errors information, where the program 

stops etc. 

Run and Alarm led can be set by manual here also, current connected controller can be found 

rapidly in multi-controller. 
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Error information:  

 

7.7  Bus State Diagnosis  

“Debug” – “Bus State Diagnosis” window can see the current bus supported by controller and 

device information of all nodes connected by bus. 

Print information definition refers to “?*ETHERCAT” for help. This window’s data result 

same as ?*ETHERCAT and ?*RTEX. 
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7.8  Status Bar 

Status bar shows 3 parts, which can be used to show cursor positioning, printed information 

counting, controller mode/IP/status. 

1. Cursor positioning:  

show line and row information of cursor place (such as, Basic, line 23, row 1, 437 characters 

numbers indicate there are 16 lines program in the front of cursor, cursor is in behind the first 

character of this line, there are 437 from first line to cursor position; PLC, ROW:30, Col:2, which 

means cursor is in the second grid position of line 30). 

2. Count printed information: 

Count error information of current instructions and output window, alarm, the number of 

printed information. 

3. Show controller mode/IP/status: 

Show current connected controller mode/IP/running status, when there is ALM or ERROR, a 

hint will appear in right corner in red background. 

If there is no controller connected, red fond “Unconnected” in right corner. 



                                          ZDevelop User Manual Version V3.10.04 

70 

 

 

Controller runs normally, there show “Running” status 

 

Controller doesn’t run or emerge stop, there shows “idle” 

 

Click “Debug” – “Pause”, program scanning pause: 

 

There is “Red” hint in motion: 

 

    We can see from the above, axis 0 axis alarm, customer can check axis0 axisstatus or check 

printed information. 
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Chapter VIII  Common Errors 

When errors come in operating project, ZDevelop will show error information, take it for 

reference to help debugging, we can also view errors by typing in command:?*task in ZDevelop 

command box, double click error information to reach related code lines. 

Error Reasons or Solutions 

Download button is gray 

1.project not built or no files in project.  

2.not connected with controller. 

3.some controllers only support ROM download, RAM is 

not valid. 

WARN: no program set autorun. 1.no file with auto run task number. 

Error:5002, Operate Failed! 
1.there are more than 1 HMI file or task in project, delete 

redundant HMI files. 

Controller alarm Led is on 

1.input “?*task” to check error information again 

2.check if axis status values are 0 through AXISSTATUS 

3.check print information in command and output window. 

Manual operation did not work.  

1.check axis parameter: AXISSTATUS, to view if any 

error happens, especially position limit or alarm. 

2.see ATYPE if relative axis is 0, if it is set as encoder. 

3.check axis UNITS value, if it is too small or just is 0. 

4.check motor wiring 

Manual operation only works in 

one direction  

1.check axis parameter: AXISSTATUS, to view if any 

error happens, especially position limit or alarm. 

2.check if the drive double pulse setting same as controller, 

view controller setting through INVERT_STEP。 

3.check motor wiring, especially direction wire. 

 

 


